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VLC media player (commonly known as just VLC) is a free and open source cross-platform multimedia player and
framework that plays most multimedia files as well as DVDs, Audio CDs, VCDs,and various streaming protocols.
You can download the latest version of VLC on our website for free.
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CHAPTER

ONE

KEY FEATURES

• VLC plays Files, Discs, Webcams, Devices and Streams.

• VLC runs on all platforms and is completely free.

• It has the most complete feature-set over the video, subtitle synchronisation, video and audio filters.

• It has hardware decoding on most platforms. It supports 0-copy on the GPU and can fallback on software when
required.

• No spywares, ads and user tracking are allowed on the VLC media player.

• Advanced formats are allowed on VLC.

• VLC lets you apply audio effects, video effects, and tweak the way a video’s audio and video line up.
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CHAPTER

TWO

FIRST STEPS

To get the most out of the VLC media player, start by reviewing a few introductory topics below;

• Setup - Quickly find and install the appropriate VLC media player for your platform.

• User Interface - Introduction to the UI, and commands of the VLC media player.

• Settings - Customize VLC to suit your needs.

• Tips and Tricks - Jump right in with Tips and Tricks to become a VLC power user.

• Add-ons - Find third-party software programs that can be added to VLC for additional features and abilities.

• FAQ- Find all frequently asked questions by VLC users.

• Support Guide - Solve your VLC issues right now!

• Glossary - Definitions for terms used in VLC and this documentation.

2.1 Getting Started

2.1.1 Installation

The VLC media player is available for desktop operating systems and mobile platforms such as Microsoft Windows,
macOS, Linux, Android, iOS, FreeBSD, Solaris, QNX, Haiku, and Syllable Desktop. VLC is also available on digital
distribution platforms such as Apple’s App Store, Google Play and Microsoft Store and supports many audio and video
compression methods and file formats, including DVD-Video, video CD, and various streaming protocols.

It is able to stream media over computer networks and to transcode multimedia files. Overall, the installation process
of the VLC media player is quick and easy. Follow the platform specific guides below:

Windows

1. Open the VLC website on your browser.

2. Click on Download VLC to download the VLC media player automatically onto your computer.

3. Once it is downloaded, double click on the VLC setup file to begin the installation process. You’ll find it in the
default downloads location for your browser.

Note: The operating system may prompt you to grant VLC administrator permissions if you have UAC (User Account
Control) enabled on Windows Vista, 7, 8 or 10. If this happens, click Yes when prompted to continue the installation
process.
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4. Click on the drop-down box and select the language that you want the installer to use to display information to
you and click OK to proceed.

5. The VLC installer recommends that you close all other applications before continuing the installation process
(this is not com[ulsory]). When you’re ready to proceed with the installation process, click Next

6. Click Next on the setup guide displayed on your Windows pc.

7. Click Browse to choose a destination installation folder of your choice. After you’ve identified the desired
folder, click Install. Doing so installs VLC media player on your computer.

8. After a few minutes, the VLC media player will be successfully installed in your PC. You can see more infor-
mation about the progress of the installation by clicking on Show details.

9. Once the installation is complete, you can run it by making sure the “Run VLC media player” box is checked
and clicking Finish. When you want to run VLC in the future, you’ll have to double-click the VLC app icon on
your desktop.

10. If you marked the Run VLC media player checkbox, the VLC media player will open up immediately after
you click on Finish.

After downloading VLC on your deskptop or mobile phone, follow the guide below to start using VLC. The VLC
media palyer is shown along with an orange and white cone shown below.

Start VLC

Windows XP: Click Start -> Programs -> VideoLAN -> VLC media player.

Windows 7: Click Start -> All Programs -> VideoLAN -> VLC media player.
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Windows 10: Click on the Windwos icon. Applications are arranged alphabetically, so you can either scroll down to
letter V or search for VideoLAN. On seeing the VideoLAN folder, click on it to find the VLC media player. Go
ahead and click on VLC Media Player. After this, the all format video player will open.

A simpler way to find the VLC media Player on your PC is to type VLC on the search bar of your PC and click
on it.

Stop VLC

There are three ways to quit VLC:

• Right click the VLC icon in the tray and select Quit (Alt-F4).

• Click the Close button in the main interface of the application.

• In the Media menu, select Quit (Ctrl-Q).

Next Steps

Once you have installed and set up VLC, these topics below will help you learn more about the VLC media player:

• User Interface - Introduction to the UI, and commands of the VLC media player.

• Tips and Tricks - Jump right in with Tips and Tricks to become a VLC power user.

• Settings - Customize VLC to suit your needs.

• FAQs about VLC on Windows - Find all frequently asked questions by users running VLC on Windows.

Mac OS X

1. Open the VLC website on your browser.

2. Click on Download VLC to download the VLC media player automatically onto your computer.

3. If prompted, select a download location. Else, skip this step.

4. Once it is downloaded, go to the folder into which your browser downloads files, then double-click the VLC
DMG file. This will open the installation window.

5. Click and drag the VLC app icon onto the Applications folder. The “Applications” folder is on the right side
of the window, while the traffic cone-shaped VLC app icon is on the left. Doing so will install VLC on your
computer.

6. Double click on VLC media player app icon and wait for your mac to verify VLC.

2.1. Getting Started 9
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7. Click Open when prompted. VLC Media Player will launch for the first time. Use it to play all your media with
ease.

After downloading VLC on your deskptop or mobile phone, follow the guide below to start using VLC. The VLC
media palyer is shown along with an orange and white cone shown below. Start VLC from the applications menu or
the system dock.

Clicking this icon shows or hides the VLC interface. Hiding VLC does not exit the application. VLC keeps running in
the background when it is hidden. Right clicking the icon in the notification area shows a menu with basic operations,
such as opening, playing, stopping, or changing a media file.

After downloading VLC on your deskptop or mobile phone, follow the guide below to start using VLC. The VLC
media palyer is shown along with an orange and white cone shown below.

Start VLC

Open your Macbook and click on Launchpad to find all the applications on your PC. At this point, you can either
search for VLC or scroll down to find the VLC cone icon.

Stop VLC

There are three ways to quit VLC:

• Right click the VLC icon in the tray and select Quit (Alt-F4).

• Click the Close button in the main interface of the application.

• In the Media menu, select Quit (Ctrl-Q).

Next Steps

Once you have installed and set up VLC, these topics below will help you learn more about the VLC media player:

• User Interface - Introduction to the UI, and commands of the VLC media player.

• Tips and Tricks - Jump right in with Tips and Tricks to become a VLC power user.

2.1. Getting Started 11
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• Settings - Customize VLC to suit your needs.

• FAQs about VLC on Mac OS - Find all frequently asked questions by users running VLC on Mac OS.

Linux Distributions

Ubuntu

Installing the VLC media player on the Ubuntu operating system can be done in three different ways;

Installing VLC Using Ubuntu Software center

1. Click on the Show Applications button or search for Software on the search bar and open it.

2. Click the search button on the top right and search for VLC.

3. Click on Install. If required, authorize the autorization with your password.
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The application will automatically download and install on your Ubuntu machine.

Download VLC through your Command Prompt

1. Click on the Show Applications button.

2. On the search bar, type in Terminal, and open it.

3. On your terminal, run the following commands sudo apt-get update and provide the sudo password for
authentication

4. Run sudo apt-get install vlc on your terminal to install VLC on your system. When you are asked
this question; Do you want to continue? [y/n] type in y (short form for YES)

Debian

1. Open the VLC website on your browser.

2. Click on Get VLC for Debian GNU/Linux to see a list of stable releases of VLC for download.

A standard install without libdvdcss:

# apt-get update
# apt-get install vlc <optional extra components>

Or search for vlc with the graphical package manager you like best. It should be in the main Debian repository in the
section Video software. Additional plugins are available and most require manual selection, e.g. vlc-plugin-access-
extra, vlc-plugin-notify and vlc-plugin-jack.

A standard install with libdvdcss:

A simple install of the libdvdcss package can be found here, but for future bug fixes add the following lines to your
/etc/apt/sources.list:

2.1. Getting Started 13
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deb https://download.videolan.org/debian/stable stable main
deb-src https://download.videolan.org/debian/stable stable main

Then:

# apt-get update
# apt-get install vlc libdvdcss2 <optional extra components>

This will allow you to decrypt DVDs.

Red Hat

Adapted (annotated) from https://www.videolan.org/vlc/download-redhat.html:

Red Hat/CentOS/Scientific Linux have almost the same setups (they’re all derived from Red Hat). Red Hat and
derivatives have different instructions if EPEL (Extra Packages for Enterprise Linux) is not set up. Red Hat Network
(RHN) users should verify that they have enabled the optionals and extras channels for RHN subscriptions.

If you want to have DVD playback ability, you will need to install the libdvdcss package too (source).

For the latest version (up to the now-current version 3.0.6) use RPM Fusion, otherwise VLC branches 2.0.x and 2.2.x
are available: Red Hat/CentOS/Scientific Linux 7: (vlc-2.2.x – branch available for x86_64 architectures)

$> su -
#> yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.

→˓rpm
#> yum install https://download1.rpmfusion.org/free/el/rpmfusion-free-release-7.

→˓noarch.rpm
#> yum install vlc
#> yum install vlc-core # (for minimal headless/server install)
#> yum install python-vlc npapi-vlc # (optionals)

Red Hat/CentOS/Scientific Linux 6: (vlc-2.0.x branch – available for i686 and x86_64 architectures)

$> su -
#> yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.

→˓rpm
#> yum install https://download1.rpmfusion.org/free/el/rpmfusion-free-release-6.

→˓noarch.rpm
#> yum install vlc
#> yum install vlc-core # (for minimal headless/server install)
#> yum install python-vlc npapi-vlc # (optionals)

SUSE

Download page: https://www.videolan.org/vlc/download-suse.html

Free BSD

Download page: https://www.videolan.org/vlc/download-freebsd.html

Install vlc from the packages collection:

# pkg install vlc
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After downloading VLC on your deskptop or mobile phone, follow the guide below to start using VLC. The VLC
media palyer is shown along with an orange and white cone shown below.

Start VLC

Open your phone, click on the cone icon and enjoy using the VLC Media Player.

Stop VLC

There are three ways to quit VLC:

• Right click the VLC icon in the tray and select Quit (Alt-F4).

• Click the Close button in the main interface of the application.

• In the Media menu, select Quit (Ctrl-Q).

Android

1. Open your Android’s Google Play Store.

2. Tap the search bar at the top of the screen.

3. Type in vlc on the Search bar, then tap VLC for Android in the resulting drop-down menu.

4. On the right side of the page, click on INSTALL.

5. If prompted, tap ALLOW after clicking on the INSTALL button to confirm the download. If not, skip this step.

6. Wait for few minutes for the VLC media player to be installed on your phone.

6. You can open VLC directly from within the Play Store by clicking on Open.

7. If you clicked on Open, the VLC media player will be opened automatically on your phone.

After downloading VLC on your deskptop or mobile phone, follow the guide below to start using VLC. The VLC
media palyer is shown along with an orange and white cone shown below.

Start VLC

Open your phone, click on the cone icon and enjoy using the VLC Media Player.

Stop VLC

There are three ways to quit VLC:

2.1. Getting Started 15
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• Right click the VLC icon in the tray and select Quit (Alt-F4).

• Click the Close button in the main interface of the application.

• In the Media menu, select Quit (Ctrl-Q).

iOS

1. Open your iPhone’s App Store.

2. Type in vlc on the Search bar, then tap the blue Search button in the lower-right side of your keyboard.

3. After the search result has been displayed, click on VLC for Mobile.

4. Click on the GET button at the right of the VLC for Mobile heading.

5. Enter your Touch ID or Apple ID password when prompted or use your fingerprints.Doing so will allow VLC
to begin installing onto your iPhone.

6. You can open VLC immediately after it downloads by tapping OPEN in the App Store.

After downloading VLC on your deskptop or mobile phone, follow the guide below to start using VLC. The VLC
media palyer is shown along with an orange and white cone shown below.

Start VLC

Open your phone, click on the cone icon and enjoy using the VLC Media Player.

Stop VLC

There are three ways to quit VLC:

• Right click the VLC icon in the tray and select Quit (Alt-F4).

• Click the Close button in the main interface of the application.

• In the Media menu, select Quit (Ctrl-Q).

2.1. Getting Started 19
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Next Steps

Once you have installed and set up VLC, these topics below will help you learn more about the VLC media player:

• User Interface - Introduction to the UI, and commands of the VLC media player.

• Tips and Tricks - Jump right in with Tips and Tricks to become a VLC power user.

• Settings - Customize VLC to suit your needs.

• FAQs about VLC on Windows - Find all frequently asked questions by users running VLC on Windows.

2.1.2 User Interface

The VLC media player has several interfaces. A cross-platform interface for Windows and GNU/Linux, which is
called Qt, a native Mac OS X interface and an interface that supports skins for both Windows and GNU/Linux. The
operation of VLC is essentially the same in all the interfaces.

The main interface has the following areas:

• Menu bar - It controls everything about the media you are currently playing.

• Track slider - The track slider is below the menu bar. It shows the playing progress of the media file. You can
drag the track slider left to rewind or right to forward the track being played. When a video file is played, the
video is shown between the menu bar and the track slider.

• Control Buttons - The buttons below the track slider cover all the basic playback features.

Note: When a media file is streamed, the track slider does not move because VLC cannot know the total duration.

Windows/Linux Interface

There are 3 main parts to the VLC Media Player interface on Windows:

1. The Menu bar

2. The Playback Controls

3. Volume Controls

Menu Bar

The Menu Bar gives you power to control everything about the media you are currently playing.

static/images/interface/mainmenu_windows.png

Fig. 1: The Menu Bar

This documentation will work you through all the different features of the menu bar of the VLC media player on a
Windows Operating System.
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The Media menu

In this menu, you can:

1. Open a new file for playback from any location.

2. Stream a file to the web, local network or file.

3. Convert and Save a playlist to a file.

4. Quit VLC.

The Playback menu

In this menu, you can:

1. Select which title, chapter or program you want to play.

2. Stop the playback.

3. Move to the next or previous chapter.

4. Control the speed on the media you are playing.

2.1. Getting Started 23
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5. Jump to a specific chapter or time in the media.

6. Create custom bookmarks.

The Audio menu

In this menu, you can:

1. Select which audio track you want

2. Change the stereo mode of the media.

3. Change the device to play the audio on.

4. Enable the built in Visualizations.

5. Increase and decrease the volume.

6. Mute the playback.
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The Video menu

In this menu, you can: 1. Select which video track you want. 2. Set the video to play fullscreen and fit the win-
dows. 3. Set as wallpaper. 4. Change the zoom, aspect ratio and crop. 5. Adjust deinterlacing and post processing
options(advanced users). 6. Take a screenshot of the current frame.

The Subtitle menu

In this menu, you can:

1. Add a subtitle file.

2. Select a Sub track.

The Tools menu

In this menu, you can:

1. Change audio and video effects and filters.

2. Change the audio and subtitle symchronization.

3. View the current media information.

4. Manage plugins and extensions.

5. Customize the program settings and interface.

6. Modify your preferences.

The View menu

In this menu, you can:

1. View the current and docked playlist.

2. Change the playlist view mode.

3. Change the interface VLC is using.

4. Add an interface.

2.1. Getting Started 25
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5. Add the VLsub addon for VLC.

static/images/interface/view_windows.jpg

The Help menu

In this menu, you can:

1. Get more help using the program.

2. Check for updates to VLC.

3. View the credits and licenses for VLC.

2.1. Getting Started 27



VLC User Documentation, Release 1.0.0

Playback Controls

Here, you have access to many functions to control the playback of a media file.

static/images/interface/playbackcontrols_windows.png

Volume Controls

This allows you to increase or reduce the volume of the media file you are playing.

static/images/interface/volumecontrols_windows.png

Mac OS X Interface

The screenshot below shows the default interface in VLC 3.0.8 for Mac OS X.

The screenshot below shows the tab to click on if you need to read all the important information about VLC. Ranging
from our updates, preferences, addons mangers, about VLC media player, etc.
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The File menu:

In this menu, you can:

1. Open a new file for playback from any location.

2. Stream a file to the web, local network or file.

3. Quit VLC.

4. Save a playlist.

The Edit menu:

In this menu, you can:

1. Cut, copy, paste, Delete and select all videos.

2. You can add emoji’s and symbols and also start a dictation.

The View menu:

The Playback menu:

In this menu, you can:

1. Select which title or chapter you want to play.

2. Stop the playback.

3. Move to the next or previous chapter.

4. Control the speed on the media you are playing.

2.1. Getting Started 29
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5. Jump to a specific chapter or time in the media.

The Audio menu:

In this menu, you can:

1. Select which audio track you want

2. Change the number of audio channels.

3. Change the device to play the audio on.

4. Enable the built in Visualizations.

5. Increase and decrease the volume.

6. Mute the playback.

2.1.3 About VideoLAN

Introduction

The VideoLAN project is led by and composed of a team of volunteers who believe in the power of open source to
rock the multimedia world supported by the VideoLAN organization, based in France. The VideoLAN non-profit
organization has a committee and members that are part of the VideoLAN project.

The current board of VideoLAN organization is composed by:

• President: Jean-Baptiste Kempf

• Vice President: Konstantin Pavlov

• Treasurer: Denis Charmet

• Secretary: Hugo Beauzée-Luyssen

Open Source

VideoLAN produces free software for multimedia, released under the General Public License.

2.1. Getting Started 31
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Hosted projects

VideoLAN hosts many open source projects, related to multimedia, including the famous VLC. Check the list of
projects.

Events

We regularly attend computing events, like FOSDEM (Free-software and Open Source Developers European Meeting).
We generally come back with some photos and stories.

Contact

Please see contact page for important queries, questions and remarks.

VideoLAN’s History

The VideoLAN project was started as a school project in 1996 by students of Ecole Centrale Paris, a French engineer-
ing school in 1996. These students wanted to be able to watch television on their PCs. They also wanted to upgrade
the VIA Centrale Réseaux network so they needed a bandwidth intensive application to justify the upgrade. So they
began writing VLS (VideoLAN Server) and the VLC (VideoLAN Client) to stream and read MPEG-2 streams. They
succeeded in serving and reading the first stream in 1998. These two programs were planned to be modular, which
meant a core consisting basically of communication functions to be used by the modules. This allowed easy porting
of the OS specific modules.

In 2001, after many months (if not years) of negotiation, the school’s Director agreed to a change to the GPL licence.
Developers from all around the world started working on the project right away. One of them (gibalou) even submitted
the Win32 port 6 months later! The first large scale multicast streaming tests occurred in May 2002. 500 students on
the VIA Centrale Réseaux network were able to participate in these tests. In January 2003, the first MPEG4 streams
were tested and realtime MPEG4 encoding was available two months later.

2.1. Getting Started 33

https://www.videolan.org/vlc/
https://www.videolan.org/projects/
https://www.videolan.org/videolan/events/
https://www.videolan.org/contact.html
https://www.centralesupelec.fr
https://images.videolan.org/images/paper.jpeg


VLC User Documentation, Release 1.0.0

Overview of the VideoLAN project

The project started to open up to developers outside of the École. It is now a worldwide project with developers
from 40 countries. Since 2009, the project is completely separated from École Centrale Paris, and is driven by an
autonomous non-profit organization.

VLC used to stand for VideoLAN Client when VLC was a client of the VideoLAN project. Now, the initialism
no longer applies because VLC is no longer merely a client. Originally VideoLAN was designed to stream MPEG
videos on high-bandwidth networks, but VideoLAN’s main software, VLC media player, has evolved to become a
full-featured, cross-platform media player. Now, the Non-Profit Organisation developing and offering the VLC media
player is called: VideoLAN Organisation.

VLC Media Player

Originally called VideoLAN Client, VLC media player is VideoLAN’s main software product. VLC media player
works on many platforms: Linux, Windows, macOS, BeOS, BSD, Solaris, Android, iOS, QNX and many more. . .
It supports the following video and audio formats: MPEG-1, MPEG-2, MPEG-4/DivX, h264, webm, mkv, DVDs,
VCDs, Audio CDs, wmv and wma. It can also play from external sources:

• Satellite.

• Cable.

• Digital TV cards (DVB-S, DVB-T).

• Several types of network streams: UDP/RTP Unicast, UDP/RTP Multicast, HTTP, RTSP, MMS, etc.

• Acquisition or encoding cards.

• Webcams and other devices.

• VLC can also be used as a streaming server.

The VideoLAN Community

Contribution Guidelines

As an open-source project, VideoLAN welcomes all contributions to the project and we encourage the community to
submit patches directly to VideoLAN or help with our documentation, packaging, tests, user support, material or even
money.

How to contribute to VideoLAN

Give time

If you have time, we welcome your help in various areas:

• Programmer: Help us submit patches to the codebase of VLC.

• Writer: Writers help us improve our documentation.

• Translators: As a translator, you can help us to translate VLC or other projects.

• Moderators & Support: To answer on the forums and mailing lists.

• Designers: We encourage designers to join us and create designs for this website and the VLC media palyer.

34 Chapter 2. First Steps
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You should see the developer documentation, subscribe to our various mailing-lists, have a look at the bug-tracking
system, join the IRC channel to get help on how to start coding.

Contribute materials

Your particular DVD, VCD or SVCD does not work with VLC? You have a satellite card or an MPEG encoding card
that is not supported by some VideoLAN software?

You can donate it to the developers and it may motivate them to work on your suggestion! In any case, you do not
have any warranty that your wish will be taken into account.

If you want to donate materials, please contact us.

Donate money

What are the financial needs of VideoLAN?

Buy hardware for developing and testing purposes (DVDs, satellite cards and antenna, MPEG encoding cards,. . . )
Maintain the servers and hardware to run VideoLAN services. Promote the project by organizing or participating
in events (FOSDEM, Linux Expo Paris, . . . ) What is the legal structure of VideoLAN? VideoLAN is a non-profit
organization, under French law. VideoLAN has its own bank account and is responsible for running and maintaining
the VideoLAN servers.

Donate to VideoLAN via PayPal

You can donate money to the project through VideoLAN’s PayPal account. There is no minimal amount for your
donation.

If you click on one of the buttons below, you will be taken to the secure PayPal Web site. You don’t need to have a
paypal account in order to make a donation.

• Euros C Donate money to VideoLAN via PayPalDonate money to VideoLAN via PayPal

• Dollars $ Donate money to VideoLAN via PayPalDonate money to VideoLAN via PayPal

If you encounter problems or if you have questions, you can contact us.

Donate to VideoLAN via Bank account

VIDEOLAN

IBAN: FR76 3000 3034 3000 1506 8853 588

BIC/SWIFT: SOGEFRPP

FRANCE

Donate to VideoLAN using Monero

Use this address: 41gP4569HkeAJPcqSTizJYiMcMZVQekGvAAgAucaVCwaNsm
bSrkcFY41w4FwgtD6N5XLV88xwrLjn87dpjUbtZJoDUuSeJF or the QR-Code below:

Donate to VideoLAN using Bitcion

Use this address: 3EowKLZ7Gf86BrHad7XXNpFk8jfXBeNPuF or the QR-Code below

Getting Support

VLC is a free and open source software which means that most developers are volunteers. Therefore, please remember
that every user support is provided by volunteers doing it in their free time. If you have problems that has not been
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answered on our Frequently Asked Questions page, you can reach out to us diretly through any of the methods listed
below;

IRC

The VideoLAN IRC channel is a good way to contact and speak with the team. Using an IRC client, connect to
irc.videolan.org or irc.freenode.net and go on the #videolan channel. If you are in a location without direct IRC
access, please try the Freenode Webchat.

Forum

Search or ask your question on the VideoLAN support forum

Email

To contact us by e-mail, send a mail to videolan@videolan.org and write in either French, German or English.

Mail

If you need to send a postal mail to us, kindly mail it to the address below;

Postal Address
VideoLAN
18, rue Charcot
75013 Paris
France

2.2 User Guides

2.2.1 Media

Playing a file

To play a file, open the Media menu as seen in the picture below:
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Then select the Open File menu item.

An Open File dialog box will appear. Select the file you want to open and select Open.

After you click Open, VLC will then start playing the designated file.

An alternative to the aforementioned step is to simply drag and drop your file into the VLC main interface or the
playlist window from the File explorer on Windows and Finder on Mac OS X

Playing a CD/DVD/VCD/Blu-ray

To play a CD, VCD or a DVD, open the Media → Open Disc menu item.

In the Open Disk dialog box as shown in the diagram below, select your preferred media type (DVD, Blu-ray, Audio
CD, or SVCD/VCD).

You can either select the drive in which the media is located by selecting the drive letter from the Disc Device drop-
down list, or you can click the Browse button, which will open a dialog box that you can use to browse for the media
you wish to play with VLC. There is also an option for No DVD menus, when reading a DVD.

If you want to start the DVD or VCD playback from a given title and chapter instead of from the beginning, you can
set it using the Title and Chapter selectors. You can also set the Audio and Subtitles track using the selectors.

Click Play to start the playlist or Cancel to go back to the default screen of VLC.

Playing a network stream

Streaming is a method of delivering audio or video content across a network without the need to download the media
file before it is played. You can view or listen to the content as it arrives. It has the advantage that you don’t need to
wait for large media files to finish downloading before playing them.

VideoLan is designed to stream MPEG videos on high bandwidth networks. VLC can be used as a server to stream
MPEG-1, MPEG-2 and MPEG-4 files, DVDs and live videos on the network in Unicast or Multicast. VLC is also
used as a client to receive, decode and display MPEG streams. MPEG-1, MPEG-2 and MPEG-4 streams received
from the network or an external device can be sent to one machine or a group of machines.
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To play a network stream, click on Media on the menu bar and select Open Network Stream. The Open Media dialog
box loads with the Network tab selected. In the tab, enter a network URL in the text box and click on Play.

Note: When VLC plays a stream, the track slider shows the progress of the streamed file.

Playing media from an acquisition card

To play from an acquisition card, click on the Media menu → Open Capture Device menu as seen in the screenshot
below.

After clicking on Open Capture Device, a dialog box will be displayed on the screen with different options and features
to choose from. There, you can choose the preferred Capture Mode of your choice from the dropdown menu.

Aside from the afore mentioned features of VLCs capture Device, see the more capabilities below;

1. You can change the Video device name and Audio device name.

2. Users can also adjust the configuration for these devices by clicking Configure.

3. Users can set the size of the video that will be played by the Direct Show plugin and options such as Device
Properties and Tuner Properties by clicking Advanced Options.
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Video4Linux

For Video4Linux devices, you can set the name of the video and audio devices using the Video device name and Audio
device name text inputs. The Advanced options button allows you to select some further settings useful in some rare
cases, such as the chroma of the input (the way colors are encoded) and the size of the input buffer.

Hauppauge PVR card

To use a Hauppauge PVR card, select the PVR tab in the Open dialog box. Use the Device text input to set the device
of the card you want to use. You can set the Norm of the tuner (PAL, SECAM or NTSC) by using the Norm Drop
Down. The Frequency selector allows you to set the frequency of the tuner (in kHz), the bitrate selector to set the
bitrate of the resulting encoded stream (in bit/s). The Advanced Options button allows to set some more settings, such
as the size of the encoded video (in pixels), its framerate (in frame per second), the interval between 2 key frames, etc.

To start playback from an acquisition card, click Play.

2.2.2 Playback

VLC media player helps you to create media files. After creating media files, the quality has to be tested. You can
test the quality and several other parameters using playback. In playback, you can specify parameters such as time,
bookmarks, and titles.

Bookmarks

You can mark and locate particular places in an audio or video file using the Bookmarks feature of VLC. If you want
to view a particular scene in a movie or listen to certain tune in a song repeatedly, you can create bookmarks.

To bookmark a scene in a video, follow the steps below:

1. On the menu bar, click on Menu → Playback.

2. Select Custom Bookmarks. When you click on Custom Bookmarks, a dropdown menu would be displayed.
Kindly click on Manage from the dropdown menu to open the Edit Bookmarks dialog box.

3. To create a bookmark, click on Create to display the current track. After clicking on Create, the created book-
mark appears in the Edit Bookmarks dialog box.

4. To view a scene that is bookmarked, click on Playlist, and select the Custom Bookmarks from the dropdown
menu and the bookmarked file will be shown directly below Manage.
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Title

In a DVD format, each movie is referred to by its title or name. A title is displayed whenever a movie is played by any
media player. You can view all titles in a folder in a sequential manner.

1. To open a folder, select Menu → Open Folder from the menu. Locate the folder in which the video files are
present and click OK.

2. To select a title, click on the Playback → Title menu. The selected title is then played.

Chapter

A video can also be divided into chapters. Different chapters can be accessed at random in a video which is being
played. Using this option, you can directly view your favourite chapter without having to see the complete video.

To play a chapter:

1. Select Menu → Open Folder menu.

2. Locate the folder in which the video files are present.

3. Select a video file and click OK and the file will be played in the VLC media player.

4. Select Playback → Chapter in the menu to view the list of chapters. Select a chapter of your choice. Then
selected chapter is played.

Program

This option is enabled only if streams of format DVB (Digital Video Broadcasting) and TS are played. Choose the
program to select by giving its Service ID. Only use this option if you want to read a multi-program stream (like DVB
streams for example). FIXME: Description needs to be improved

Specify the time

This option is used to go to a specific frame in a media file and listen or view once again.

1. To specify time select Playback → Jump to Specific Time menu. The Go to Time dialog box is displayed.

2. Enter the time in hh:mm:ss.

3. Click on the Go button. The control moves the tracker to a specific frame and the media file continues from that
specified frame.

4. Click on Cancel to exit the dialog box.

Warning: Ensure that time limit is within the range of length of the media file.
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2.2.3 Audio

The VLC media player can play several audio formats: .asf, .avi, .divx, .dv, .mxf, .ogg, .gm, .ps, .ts, .vob, and .wmv.
It can also convert audio tracks and use several visualizations.

Note: The commands in the Audio menu are only enabled when an audio file is being played.

Playing an audio track

To play a track, follow the steps below:

1. Select the Media → Open File menu.

2. Select an audio file and click on the Open button. Immediately after that, the selected track will be played on
my VLC.

Enabling and disabling audio tracks

On VLC, you have the option to disable and enable a track.

Disable

Select the Audio → Audio Track menu and click on the Disable option from the dropdown menu to stop the selected
track.

Enable

To enable the track again, select the designated Track in the Audio → Audio Track menu.

Recording Audio

Recording the audio of any track you are playing is also allowed on VLC. However, the record button used for this is
hidden by default. To make the Disable button visible, use one of these methods below:
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Advanced Controls

Click on View → Advanced Controls to display the advanced toolbar directly above Playback Controls. This advanced
toolbar contains the Record button. Once the Record button is visible, click it to start recording.

Customize interface

Select Tools → Customize interface menu and drag the record button to to any location of your choice in Line 2. Once
the Record button is visible, click it to start recording.

Note: Line 2 is the default line shown on VLC.

The recording from a shoutcast stream is stored on the default storage folder for videos or mu-
sic on your computer under a name like vlc-record-Date-Time-Channel-Track.mp3 Example:
vlc-record-2011-09-22-10h19m48s-Radio CAFF-Silencio - Arrabal Salvaje.mp3.

You can automatically cut the stream into tracks by relaying the stream through Streamripper, i.e. by directing
StreamRipper to the ShoutCast stream and directing VLC to the relaying port of StreamRipper (default
http://localhost:8000).

Stereo Mode

This option helps you to listen to audio files in two modes Stereo and Mono.

To listen to an audio track in either the Stereo or Mono mode:

1. Click on Media → Open File or Open Disc from the dialog box displayed on your screen.

2. Select an audio file and click on the Play button.

3. Select Audio → Audio Device → Mono if you want to listen to the audio track in the Mono mode.

4. Select Audio → Audio Device → Stereo if you want to listen to the audio track in the Stereo mode.
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Visualize Audio

Visualizations display splashes of colour and geometric shapes and generate animated imagery based on a piece of
music. Select the type of visualizations option from the Audio menu to view the effects. The different visual effects
available are:

• Spectrometer

• Scope

• Spectrum

• VU Meter

• Goom

• projectM

• 3D Spectrum

To disable visualizations, click on Visualizations → Disable drop down menu.

Maximum VLC Volume

To change the maximum volume in of an audio file, go to Tools → Preferences, select All at bottom left corner, then
Interface → Main interface → Qt → Maximum volume displayed. Then Save it and restart VLC.

2.2.4 Video

You can play video files, video clips and other video media using the VLC media player. You can resize, change aspect
ratio, crop videos, load subtitles, deinterlace, save snapshots, and convert videos to DirectX wallpaper.

Video tracks of the .asf, .avi, .divx, .dv, .mxf, .ogg, .gm, .ps, .ts, .vob, and .wmv formats are supported.
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Playing a Video Track

There are two main ways to open and play a video track:

1. Select Media → Open File.

2. Select a video track and double-click it or click the Open button to play the file.

Full Screen

This option is useful if you want to watch the video in the full screen mode.

1. Select Video → Full Screen. The video will then occupy the entire screen.

2. To return to the original mode, press Esc on the keyboard or right-click the mouse and select the Leave Full
Screen option. The video will then return to its original mode.

Note: When you switch to full screen, the controls may appear for a short period of time. To restore the controls after
they disappear, move the mouse or press any key on the keyboard.

Snapshot

This option is useful if you want to capture a portion of the video as an image. To capture an image from the video,
Click on Video → Take Snapshot.

The image is captured in the .png picture format and is saved in the My Pictures folder by default
(C:\Users\Username\Pictures).

Zoom

You can enlarge videos in different sizes. This option is useful if you want to change the size of a video track which is
being played. The supported sizes are 1:4 Quarter, 1:2 Half, 1:1 Original (default) and 2:1 Double. To view a video in
a particular dimension, select a dimension in Video → Zoom.
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The track is then resized based on the selected zoom ratio.

Aspect Ratio

Aspect ratio refers to the width of a picture in relation to its height. For example, the ratio 4:3 means four units wide
to three units high. VLC provides a list of aspect ratio values which are Default, 1:1, 4:3, 16:9, 16:10, 2.21:1, 2.35:1,
2.39:1 and 5:4.

To select an aspect ratio, select a value from Video → Aspect Ratio menu. Then video is then adjusted based on the
selected ratio.

Crop

This option is helpful if you want to capture a small portion of a video as an image. This also helps crop the black bars
of the top and bottom of a video.

The cropping values that are supported are Default, 16:10, 16:9, 1.85:1, 2.21:1, 2.35:1, 2.39:1, 5:3, 4:3, 5:4, and 1:1.

To crop a video that is played, select a value from Video → Crop menu. The video is then cropped based on the
selected value.
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Deinterlace

Deinterlace refers to a process where interlaced video signals are converted into non-interlaced signals. VLC provides
the Discard, Blend, Mean, Bob, Linear, X, Yadif and Yadif (2x) deinterlacement modes.

You can achieve deinterlace by following the steps below:

1. Select Video → Deinterlace menu and choose the appropriate setting.

2. To change the deinterlacement mode select Video → Deinterlace mode

3. Select a mode and observe the change in the video being played.

2.2.5 Subtitles

A subtitle is a textual version of a movie’s dialogue. Subtitles are helpful if you are viewing a movie that contains
foreign language(s). In VLC, subtitles of the formats .cdg, .idx, .srt, .sub, .utf, .ass, .ssa, .aqt, .jss, .psb, .rt and smi are
supported.

Media with included subtitles

Many types of media can have embedded subtitles. VLC can read subtitles for the following media formats:

• DVD

• SVCD

• OGM files

• Matroska (MKV) files

Subtitles are enabled by default in VLC media player. To disable them, click on the Subtitle menu to find available
subtitles tracks for the file and select Disable to turn off the subtitles. Depending on the media, a description (language,
for example) might be available for the track.

To disable subtitles by default, go to Tools → Preferences → Subtitles/OSD, then uncheck the Enable subtitles check-
box and click Save.

DVD and SVCD subtitles are merely images, so you won’t be able to change anything for them. OGM and Matroska
subtitles are rendered text, so you will be able to change several options.

Font modifications

Text rendering options can be changed in the Tools → Preferences tab. To change the font type and size, click on
Videos → Subtitles/OSD and from the dropdown menu of Font and Font size, choose your preferences.

You need to restart your stream for the font modifications to take effect.

Subtitles files

While modern file formats like Matroska or OGM can handle subtitles directly, older formats like AVI can’t. Therefore,
a number of subtitles files formats have been created. You need two files: the video file and the subtitles file that only
contains the text of the subtitles and timestamps.

VLC can handle these types of subtitles files:

• MicroDVD

2.2. User Guides 53



VLC User Documentation, Release 1.0.0

• SubRIP

• SubViewer

• SSA

• Sami

• Vobsub (this one is quite special: it is not made from text but from images, which means that you can’t change
the fonts)

To open and use a subtitles file, click on the use a subtitle file check box as seen in the picture below from the dialog
box that appears when you click on Open Multiple Files. . . and select your file by clicking on the Browse button.
There is also an option to set character encoding, alignment and size.

An alternative is loading subtitles from the Video → Subtitle Track menu.

Note: For Vobsub subtitles, you need to select the .idx file, not the .sub file. Encoding, alignment and size won’t have
any effect for Vobsub subtitles.

2.2.6 Hotkeys

VLC Hotkeys are keyboard shortcuts you can use even if VLC does not have the focus. Here, we show you the most
used hotkeys and also a full list of the global hotkeys allowed in VLC.
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Most Used

Find below a list of most used global hotkeys in VLC:

Action Hotkey
Fullscreen f
Exit fullscreen Esc
Play/Pause Space
Stop s
Faster +
Slower -
Normal rate =
Next n
Previous p
Volume up ctrl + Up
Volume down ctrl + Down
Mute m
Jump backward Shift + Left
Jump forward Shift + Right
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Full List

2.3 Settings

It is easy to customize VLC to suit your needs through its various settings.

2.3.1 Preferences

This menu gives you access to all the settings that establish the behaviour of VLC. Each section of preferences comes
in two flavours: Simple and Advanced. The simple preferences are settings for the most commonly used parameters of
the application while the advanced settings require some deeper knowledge to use them effectively.

Where to find VLC preferences

To open the Preferences panel, select Tools → Preferences.

Here is the Simple Preferences panel where you can modify the essential settings of VLC.

How to reset the VLC preferences

Many problems with VLC are due to incorrect settings or a broken plugin cache. You can solve these by deleting
VLC’s preferences and cache. To do this, open VLC on computer, click on Tools → Preferences → Reset Preferences.

Preference sections

Interface Choosing and configuring an alternate interface.

Audio Allows you to choose the type audio to play through which channels.
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Video An option to choose which video to play through which channels.

Subtitles/OSD Here, you can make changes to subtitles and On Screen Display Settings.

Input / Codecs How to interpret the video file/stream.

Hotkeys Keyboard shortcuts used in VLC.

2.3.2 Adjustment & Effects

VLC allows you to add adjustments and effects to the playing Video or Audio file.

Audio Effects

Equalizer

VLC features a 10-band graphical equalizer, a device used to alter the relative frequencies of audio (e.g. for a bass
boost). You can display it by selecting Tools → Effects and Filters → Audio Effects → Equalizer on Windows or
GNU/Linux or by clicking the Equalizer button on the macOS interface.

Fig. 2: Audio equalizer in the Windows and GNU/Linux interface.

Hint: Do not forget to check the Enable button to activate the Equalizer!
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Additional Audio Effects

From the Audio Effects menu, you can also access the following effects:

Compressor emulates a dynamic range compressor

Spatializer changes audio as if it was produced inside a room

Stereo Widener enhances the stereo effect by suppressing mono (signal common to both channels) and by delaying
the signal of left into right and vice versa, thereby widening the stereo effect.

Advanced From this menu, you can adjust the audio pitch.

Video Effects

VLC features several filters able to change the video’s distortion, brightness adjustment, motion blurring, etc.

Synchronization

Synchronizing Audio and Video subtitle track is possible in VLC.

2.4 Tips & Tricks

Here are some amazing VLC Tricks & Hidden Features which will help to take your VLC experience to a totally new
level.
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2.4.1 Converting a Media File Format

VLC can convert media files from one format to another. To do that, follow the steps below:

1. Select Media → Convert/Save. The Open media dialog window appears.

2. Click Add. After you do that, a file selection dialog window appears.

3. Select the file you want to convert and click Open. The Convert dialog window appears.

4. In the Destination file text box, indicate the path and file name where you want to store the converted file.

5. From the Profile drop-down, select a conversion profile.

6. Click Start.

2.4.2 Streaming Media Files

To stream over a network with VLC, go to Media menu → Stream

In the Open Media dialog, select the media (such as a file, a network stream, a disk or a capture device) you want to
stream.

After you’ve choosen your prefered media file, click on the Stream button to display the Stream Output.

The Stream Output displays the media source you selected so click Next to continue.

The following streaming methods are available for use with VLC: Display locally, File HTTP, MS-WMSP (MMSH),
UDP, RTP and IceCast.

The most common way is via HTTP. To stream via HTTP, choose HTTP from the drop down as a “New Destination”
and click Add to implement your change. Then press Next to continue. This process also applies to other streaming
methods.
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After you click Next, a dialog box of transcoding options would be displayed on your screem. Go ahead and select a
transcoding profile that fits the codecs and access method of your stream (such as MPEG-TS, MPEG-PS, MPEG-1,
Ogg, Raw, ASF, AVI, MP4 and MOV) and click the Next button to continue.

Finally, set up any additonal options for streaming then click on Stream to start streaming.

2.4.3 Jigsaw Puzzle

Interestingly, VLC allows you to play the Jigsaw puzzle with the screens from any movie of your choice. Follow the
steps below to get started:

1. Go to Tools → Effects and Filters.
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2. On the dialog box, click on the Video Effects → Geometry tab.

3. You will find Puzzle Game close to a check box.

4. Click on the check box and choose the number of columns and rows that you want and press Close to save the
newly made changes.

5. If you were already playing a video, the video will automatically change to Jigsaw puzzle for you to play. If
you were not playing a video before enabling this feature, open a video file and the video will automatically be
displayed in the Jigsaw puzzle format as seen in the screenshot below.

Feel free to play the Jigsaw puzzle while watching any video of your choice.
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2.4.4 Take A Snapshot

Ever need to take a snapshot of a video you are watching? VLC has a way to do so. Simply use the shortcut Shift+S
on Windows and Linux or Cmd+Alt+S on macOS. The image is captured in the .png picture format and is saved in
the C:\My Pictures folder by default (C:\Users\Username\Pictures).

2.5 Add-ons

With Add-ons, you can install third-party software programs to add additional features, abilities and customization
options by using third party add-ons like extensions and plugins.

Note: Most of the VLC extensions are offered for desktop version while there are only a few for the mobile version
of the VLC app.

Here are a few things that you must know about VLC Media Player Addons:

1. When it comes to filetype, VLC Media Player add-ons generally have a .lua extension.

2. VLC Media Player add-ons are developed by third-parties, who are interested in extending the possibilities of
VLC’s usage.

3. VLC Addons are downloadable from the official VLC addon website

4. Addons or .lua files are downloaded and are copied to a location in the VLC’s program files directory to be
installed.

5. After copying the lua files, you will have to restart your VLC media player or start a new instance of the player.

2.5.1 Extensions
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Installing Extensions from our website

To do this, select your preferred extension from the official VLC addon website and download it to your
computer. After the extension has been downloaded successfully, copy the downloaded file to this location
C:\Users\UserName\AppData\Roaming\vlc\lua\extensions. Then restart VLC and voila, you’re
done.

Note: Add-ons can also be activated by clicking on Tools → Plugins and extensions → Extensions on the menu bar.

Installing Extensions diretly from VLC

If you want to install an extension directly from your VLC media player, then follow the steps below:

1. Open VLC media player on your computer.

2. On the menu bar, select Tools → Plugins and extensions.

3. On the Plugins and extensions dialogue box, you will find all the extensions and plugins created by third parties
for VLC. If you cant find any, click on the find more add-ons online. This will sync VLC withe the addons
avaliable on our official VLC addon website.

4. Click on the Extensions to see a list of available extensions. On seeing any interesting extension from the list,
click on the Install button. Voilà, you’ve successfully installed your first extension on VLC.

Installing Extensions in lua

VLC also allows you to install extensions in Lua language. Follow the steps below to get upto speed on how to do this.

1. In order to install the extension in .lua go to the file path C:\Users\UserName\AppData\Roaming\vlc\lua\extensions.
Copy the lua file to install the extension.
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2. If the lua folder is not found, simply create a folder with the name lua in the previous vlc directory. Inside
the lua folder, create another folder by name extensions and copy the lua file inside it.

3. Once the lua file is copied, the extension will be uploaded and installed.

4. Run a video in VLC media player to test and enable the extension.

2.5.2 Skins

Skins change the look of VLC Media Player and adds a bit more spice to the already superb experience. All the
available Skins for VLC can be found on our skins website.

How to use skins

You can download a variety of skins here. They usually should come as files with the extension “VLT” and is in a
zipped format. Extract the files and put the downloaded VLT files in the following folder:

• Windows: C:\Program Files\VideoLAN\VLC\skins

• Linux/Unix: ~/.local/share/vlc/skins2

• macOS: Skins are not supported on macOS.

Then open VLC on your computer, go to the Menu bar and click on Tools → Preferences → Interface and change your
look and feel from Use native style to Use custom skin.

The option of locating your desired skin should appear now, click on the Choose button and then the downloaded .VLT
file you had copied to C:\Program Files\VideoLAN\VLC\skins on Windows and ~/.local/share/
vlc/skins2 on Linux/Unix.

Note: You need to restart VLC to see the newly changed skin mode.

How to create your own skin

If you wish to create your own skin, the VLC Skin Editor enables you to create skins without any deep knowledge
how skins are made up exactly. If you’d rather want to explore all the possibilities of the skin system and get to know
how skins are made up and how to create them in detail, check out the Skins2 documentation. If you encounter any
problems while creating your skin, let us know by posting about it on the skins forum.

After youve successfully created a skin and you want others to use it, kindly upload it and fill out the form and it will
be displayed on our skins website as soon as one webmaster has checked it.

Troubleshooting

If your skin is not showing up properly on VLC, then it is possible that you choose a broken skin. To solve this, switch
back to the default interface by going to the Menu bar and clicking on Tools → Preferences → Interface and finally
changing your look and feel back to Use native style.

Note: You need to restart VLC to see the default interface.
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2.6 Support

The VLC Support Guide is an infromal, step-by-step guide for troubleshooting most common issues with VLC.

2.6.1 FAQs

Have other challenges or don’t see your issue outlined below? Please report a bug or request a feature and join the
forum for discussions.

VideoLAN

What is VideoLAN?

VideoLAN is a group of people that produce and distribute free and open-source software for video and multimedia
purposes, released under Open Source licenses. It started as a student project at the French École Centrale Paris, but
is now a worldwide project with developers from everywhere and dozens of millions of people using VideoLAN’s
software.

What is the legal structure of VideoLAN?

VideoLAN is a French non-profit organization. VideoLAN has its own bank account and is fully responsible for this
website.

What are the differences between VLC, VLC media player, VideoLAN Client, VideoLAN Server and
VideoLAN?

VLC media player is the official name of VideoLAN’s main product, most often called VLC. VideoLAN Client is
a former name of this product. VideoLAN Server is another product of VideoLAN, but is discontinued since VLC
media player can do more. VideoLAN is NOT a software, see VideoLAN.

How can I contribute to VideoLAN?

You might either contribute time, material, or money. You DON’T NEED to be a programmer to help us. Translators
are always welcome. You will find all the information you need on the contributor page.

Why is the VideoLAN mailing-lists and website in English?

VideoLAN’s developers come from all around the world and english is the only language they can use to communicate
together. Although great care is given to the translation of VLC in various languages, maintaining translations of our
website costs too much more time than we can afford.

See also:

Get Help - Find an answer to any question that wasnt answered here.

VLC Media Player

Find all frequently asked questions by VLC users below;
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Does VLC support DVDs from all regions?

This mostly depends on your DVD drive. Testing it is usually the quickest way to find out. The problem is that a
lot of newer drives are RPC2 drives these days. Some of these drives don’t allow raw access to the drive untill the
drive firmware has done a regioncheck. VLC uses libdvdcss and it needs raw access to the DVD drive to crack the
encryption key. So with those drives it is impossible to circumvent the region protection. (This goes for all software.
You will need to flash your drives firmware, but sometimes there is no alternate firmware available for your drive). On
other RPC2 drives that do allow raw access, it might take VLC a long time to crack the key. So just pop the disc in
your drive and try it out, while you get a coffee. RPC1 drives should ‘always’ work regardless of the regioncode.

Where does VLC store its config file?

Currently, a config file is created on a per user basis (there is no global configuration file). If you modify the available
options in VLC and save the new configuration, then a configuration file will be created in your user directory. The
precise location of this file depends on the Operating System you are running:

Linux/Unix

• $(HOME)/.config/vlc/vlcrc (v0.9.0 and above)

• $(HOME)/.vlc/vlcrc (v0.8 and older)

macOS

• HOME/Library/Preferences/org.videolan.vlc

• HOME/Library/Preferences/VLC (v0.9 and older)

Windows

• 95/98/ME: C:\Windows\Application Data\vlc\vlcrc

• 2000/XP: C:\Documents and Settings\%username%\Application Data\vlc\vlcrc

• Vista/7: C:\Users\%username%\Application Data\vlc\vlcrc

• BeOS: config/settings/vlcrc

Videos are too dark!

Often this is caused by video hardware overlay problems:

• If it is only one video then use the Settings menu, option Extended GUI and try to increase the Gamma value
in the Video tab.

• Check your video card settings and turn off hardware video overlay. If the videos now play with proper lighting,
then deinstalling and reinstalling the video drivers might help.

I cannot read DVDs!

Here are a few things to check:

• If you are on Linux/Unix, did you install the libdvdcss package?

• Do you have write access to your DVD device? For instance, from the console: # chmod 666 /dev/dvd
where /dev/dvd is the device corresponding to your DVD drive.
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Video is choppy

Your system might be too slow to decode all pictures. It might be that your CPU basically is not fast enough. It can
also be that the subsystem is misconfigured/misdriven, this happens for example under Redhat Linux. Here are some
elements to improve speed:

• Turn on DMA on your DVD device, for instance:

– Under Linux: # hdparm -d1 /dev/dvd

– Under Windows, go to the System section of the control panel, and go to the Hardware manager (it is
sometimes in a separate tab, and sometimes, you have to go to the Advanced tab. Then, righ-click on
your DVD player, and check the DMA checkbox.

• Upgrade to the latest driver for your video board.

• Stop other running applications.

• Try disabling framedropping. Framedropping allows VLC not to decode some pictures when the CPU is over-
loaded, but can result in choppier playback under certain conditions. Framedropping behaviour can be config-
ured in the Video preferences of VLC.

Audio and video are out of sync!

Try using another audio output plugin and, under Unix, kill esd, artsd or pulseaudio if they are running. If the
problem is due to the input file, have a look at the Audio desynchronisation compensation option.

Why is my VLC crashing?

Increase the verbosity level (either in the preferences or with a -vv command line option) and look at the debug
messages (in the terminal or in the Messages window).

If you are convinced that it is a bug in VLC, have a look at the bug reporting page.

How can I take screenshots?

To take a snapshot of the video displayed by VLC, you just need to press the pre-defined snapshot hotkey:

• Windows/Linux/Unix: Ctrl + Alt + S

• Mac OS X: Command + Alt + S

To change it, go to Preferences → Interface → Hotkeys settings, check Advanced options, and set Take video snapshot.
You can also take a snaphot via the menu Video → Snapshot. To change the snapshot format or directory, go to
Preferences → Video.

Where are my screenshots?

If you haven’t changed the snapshot directory in your preferences, your screenshots should go to:

• Windows: My Documents\My Pictures\

• Linux/Unix: $(HOME)/.vlc/

• macOS: Pictures

To change it, go to Preferences → Video → Video snapshot directory.
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Why is my file not working on VLC?

Are you sure VLC supports the file? Try checking the features page. If it supported and you compiled VLC yourself,
check if you have downloaded and installed all the codecs correctly. If it is not supported, then you are out of luck for
now.

Why isn’t VLC displaying all subtitles?

If VLC has autodetected your subtitles file, or if you opened it manually, but VLC only displays some subtitles
from time to time, you will need to change the subtitles file encoding. To do this, go to Tools → Preferences →
Subtitles/OSD, and select the right encoding format for your PC in the dropdown menu and click Save.

Are there skins with a full screen controller?

Full screen controllers in skins are supported since VLC 1.1. But apart from the default skin coming with VLC not
many other skins have this feature.

See also:

Get Help - Find an answer to any question that wasnt answered here.

FAQs about VLC on macOS

Can I run VLC on Mac OS 9

VLC will not work on mac OS 9, and probably never will. However, VLC is supported on Mac OS X .

The VLC 0.8.1 doesn’t work with Mac OS X 10.1.5, why?

It doesnt work because we do use functions which aren’t available in this version. The 0.7.0 release is the last one
which supports this OS. Additionally, you shouldn’t use it anymore, since 10.2 is much faster than 10.1.5 even on
older Macs.

Which is the last release for 10.2.8?

That’s VLC 0.8.4a. Note that it requires QuickTime 6.5.2, which is the latest QuickTime version for this Mac OS X
release series. With prior versions, you’ll get an unexpected video output results.

Why doesn’t VLC 0.8.6a work on 10.3, although you state it does?

First of all, make sure that you got 10.3.9 installed. Any earlier release, particularly 10.3.5 and below, doesn’t sup-
port current versions of VLC. Additionally, while QuickTime 6.5.2 is strictly required, QuickTime 7.x is strongly
recommended for performance and usability reasons.

Do current releases of VLC work on Mac OS 10.5 / Leopard?

Yes, VLC 0.8.6b runs without any problems.
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What should I do if the VLC media player on my PC bounces in the Dock and quits?

Please check whether you’re using a VLC release which is able to run on your version of Mac OS X. If it fits, run
the “Remove Preferences” script provided on VLC’s disk-image or delete both a folder called “VLC” and a file called
org.videolan.vlc.plist in ~/Library/Preferences (your personal preferences folder).

I am on Mac OS 9. Which version of VLC can I run?

From the download page notes: “There is not, and there will never be, a version for Mac OS 9.” Kindly download vlc
for Mac OS X from our main website.

How do you tell Apple’s DVDPlayer not to start automatically when you insert a DVD?

Get to Mac OS X global system preferences, open up the “CDs & DVDs” section in the “Hardware” category, add
VLC to the list of apps next to “When you insert a video DVD” and select it afterwards.

Note: Setting up VLC for Audio CD playback is possible this way as well.

Why won’t VLC play DVDs from a region other than what my drive is set to?

Many people try to use VLC to play DVDs from regions their drive is not set to. However, the DVD drives on most
new Macs have region lockout on the hardware level, so VLC will not necessarily be able to play discs from multiple
regions. You may be able to play the disc by opening it as a Video_TS folder instead of a DVD, or by changing the
method used by libdvdccss to decrypt DVDs.

In order to do this, go to Tools -> Preferences -> Input/Codecs -> Access Modules -> DVD without menus ->
Method used by libdvdcss for decryption .

If you play a lot of DVDs from different regions your best option is to buy a USB or Firewire external drive that you
can set to the region you require.

See also:

Get Help - Find an answer to any question that wasnt answered here.

FAQs about VLC on Windows

Video Output

Why does VLC only give black, white or garbled video output?

Usually the problem lies in display adapter drivers. If you are too scared to update your display adapter drivers, you
can change VLC settings to make video work. If you are using Windows XP or older, the easiest fix is usually to
disable Accelerated video output/Overlay video output which can be found first opening Tools -> Preferences and
then choosing Video. After you have disabled the Accelerated video output, save your changes and restart the VLC
media player to ensure that your changes are enabled.

If disabling Overlay video output doesn’t fix the issue, then the next step is to change the video output module (aka
VOUT). Open Tools -> Preferences -> Video and select the module of your chioce from the Output dropdown menu.
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How can I adjust brightness or contrast?

You can adjust brightness, contrast and other settings via Extended settings. Open Tools -> Effects and Filters to adjust
these settings (Video Effects -> Essential and tick Image adjust). Changes should show up realtime.

How can I keep the brightness and contrast adjustments in memory forever?

Open Tools -> Preferences (set Show Settings to All) and then choosing Video -> Filters -> Image Adjust and set
values you want to use (trial and error).

Can I set file specific brightness or contrast?

Yes, but it isn’t that easy. You have to create a VLC shortcut or .bat file with the proper settings. More info can be
found from this thread.

How do I set the default deinterlace method?

Tools -> Preferences (Show settings: All) Video -> Filters and tick Deinterlacing video filter from under Video output
filter module (NOT FROM UNDER Video filter module!). Then Video -> Filters -> Deinterlace and choose the default
mode. Remember to press Save to save VLC settings and restart VLC after that to make sure changes are enabled. [1]
image showing the Video output filter module part

VLC crashes or gives garbled images when using VMWare or VirtualBox

This is due to buggy direct3d/video emulation. Use the GDI video output in the preferences to work around this.

Audio Output

Crackles, pops, hisses and other audio anomalies

If you hear some unwanted audio problems you can try another audio output module to see if that solves the issue
(Save and restart VLC after changes). Open Tools -> Preferences (set Show Settings to All) and then choose Audio ->
Output module. There are multiple output modules you can use for audio. DirectX and Win32 waveOut should work
in most cases. Unfortunately VLC doesn’t support ASIO.

Crackles, pops, hisses and other audio anomalies with SPDIF passthrough

SPDIF passthrough of Dolby Digital (AC3) and DTS audiotracks don’t work with all soundcards. The Win32 waveOut
output module should work better with SPDIF.

I don’t hear dialog, conversations, etc. while playing 5.1 audio

Make sure you have selected the proper speaker setup from Windows audio settings or from the soundcard control
panel. If you have done so, make sure VLC also has right settings. Audio -> Audio Device to select proper speaker
settings during playback.
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How do I adjust audio delay?

During playback you can press k or j to adjust audio delay (adjust step is 50 ms).

How can I play external audio track with video?

Media -> Open (Advanced). . . and select the video file and after that tick Show more options and then Play another
media synchronously. . . and select the audio file you want to use. Then when playing the video go to Audio ->
Audio Track -> Track 2 to select the second (or whichever it is) audio track (this so-called “Slave-mode” doesn’t work
correctly).

How do I change my output device in case I have multiple audio devices connected to my PC?

Open Tools -> Preferences (set Show Settings to All) and if you use DirectX, then Audio -> Output modules ->
DirectX and Output device. If you use Waveout, then Audio -> Output modules -> WaveOut and Select Audio Device.
Remember to press Save to save VLC settings and restart VLC after that to make sure changes are enabled.

How can I override speaker setup? (e.g. I want to always default to stereo)

You can force speaker setup if you use DirectX audio output from Tools -> Preferences (set Show settings to All)
Audio -> Output modules -> DirectX and Speaker configuration dropdown menu. Remember to press Save to save
VLC settings and restart VLC after that to make sure changes are enabled.

Why does VLC volume change when I attach my mobile phone to my computer during playback?

This is a feature of Windows. You can adjust this via Control Panel. Open Sound and go to the Communications tab.

User interface

How can I separate playback controls from the playback window?

Go to Tools -> Preferences (set Show Settings to All) and Video and untick Embedded video selection. Remember to
press Save to save VLC settings and restart VLC after that to make sure changes are enabled.

How can I make skinned interface my default interface?

Go to Tools -> Preferences (set Show Settings to All) and Interface -> Main interfaces and from the Interface module
dropdown box select Skinnable Interface. Remember to press Save to save VLC settings and restart VLC after that to
make sure changes are enabled. Image about Skinnable Interface setting

Can I jump to a certain time?

You can use –start-time from command line when you start VLC. There is also Playback -> Jump to Specific Time
(Ctrl+T) option in the GUI.
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How can I change UI language?

You can use Tools -> Preferences and Interface and select the correct language from the Menus language dropdown
list. Remember to press Save to save VLC settings and restart VLC after that to make sure changes are enabled.

Also you can use –language= from command line if you can’t navigate with the current language or you want to use
batch files/scripts. For example: vlc –language=en to get English. Other options are auto, en, ar, pt_BR, en_GB, ca,
zh_TW, cs, da, nl, fi, fr, gl, ka, de, he, hu, it, ja, ko, ms, oc, fa, pl, pt_PT, ro, ru, zh_CN, sr, sk, sl, es, sv, tr

How can I disable the fullscreen controller?

You can use Tools -> Preferences (set Show Settings to All) and Interface -> Main interfaces -> Qt and untick Show a
controller in fullscreen mode option. Image about fullscreen controller setting

Why doesn’t the time slider show up?

If you use WindowBlinds or a similar custom skin engine, it usually breaks the QT4 interface in VLC. So either disable
that engine with VLC, or change VLC’s GUI to something else (like skins2).

How can I disable showing of the filename when video starts?

Go to Tools -> Preferences (set Show Settings to All) and Video and untick Show media title on video. Remember to
press Save to save VLC settings and restart VLC after that to make sure changes are enabled.

How do I disable showing of the Privacy and Network Policies dialog during first VLC startup?

Launch VLC with –no-qt-privacy-ask command-line option.

How do I disable pop up track notification shown in system tray (systray)?

Go to Tools -> Preferences (set Show Settings to All) and Interface -> Main interfaces -> Qt then untick Show notifi-
cation popup on track change. Remember to press Save to save VLC settings and restart VLC after that to make sure
changes are enabled.

How do I disable the Recent Media part of QT4 interface?

Go to Tools -> Preferences (set Show Settings to All) and Interface -> Main interfaces -> Qt then untick Save the
recently played items in the menu. Remember to press Save to save VLC settings and restart VLC after that to make
sure changes are enabled.

How do I disable the blank space at the bottom of QT4 interface? (aka Status bar)

Untick the View -> Status Bar

How do I change playlist icons to list view or vice versa in the QT4 interface?

Click the icon/button in playlist to toggle between modes.
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Codec compatibility

How can I identify what codecs the file uses?

With VLC, Open the file you want and open Tools -> Codec Information.

VLC doesn’t identify used codecs correctly or gives “undf” as codec or I want more information
about specs

There are multiple video and audio identification tools, but one very useful is tool called Mediainfo.

H.264/MPEG-4 AVC playback is too slow (or laggy)

You can speed up the H.264/MPEG-4 AVC playback by disabling loop filter for H.264 decoding. To do this go to
Tools -> Preferences and Input / Codecs and in the drop-down box for Skip H.264 in-loop deblocking filter change it
to All. Remember to press Save to save VLC settings and restart VLC after that to make sure changes are enabled.

Also if you have multicore CPU (or one with Intel Hyper-Threading), you can lower the FFMPEG thread count. To
do this go to Tools -> Preferences (Show settings: All), then Input / Codecs -> Video codecs -> FFmpeg, then locate
Threads, and set it to 4 (or to 2, or to 1). Remember to press Save to save VLC settings and restart VLC after that to
make sure changes are enabled.

H.264/MPEG-4 AVC or VC-1 playback is full of image errors

You can also try to enable/disable GPU decoding, and see if it helps. It can be found from Tools -> Preferences and
Input & Codecs and tick/untick Use GPU accelerated decoding. Remember to press Save to save VLC settings and
restart VLC after that to make sure changes are enabled.

Problem with Real Audio or Real Video getting_support

Most Real Audio and Real Video should work fine with VLC 2.0.0, but if you have a file that doesn’t work, then post
this in a thread to the support forum.

Why can’t VLC use CoreAVC, FFDshow, AC3filter, etc. codecs?

VLC only uses built-in codecs and as such, it doesn’t support VfW or DirectShow APIs for codecs. However, you are
free to hack the source and use it, though; for example it is possible to make VLC into a directshow filter.

File and Media Format Compatibility

Why does some of my DVD movies crash?

If you open a DVD with the DVD selection, try using the No DVD menus option (aka dvdsimple).

Some new DVD movies use copy protection mechanisms that VLC doesn’t support. It might help if you rip that movie
to your hard drive using tools like DVDFab Decrypter or AnyDVD, and then use VLC to play these files back locally
from your hard drive.
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You may also be able to play these copy protected DVDs by opening the movie initialization file directly. Use the
Open File function in VLC and navigate to the VIDEO_TS directory on the DVD, then open the VIDEO_TS.IFO file.
Some of the newest copy protection schemes have been found to use tricks that confuse many of the current DVD
software programs so they cannot locate this file properly to initiate playback on their own. This method has been
found to work with some of the newest DVDs that won’t open properly in VLC 1.1.11 using the standard approaches.

DVD movies don’t playback smooth

One thing that might help is increasing the VLC DVD cache. This can be done from Tools -> Preferences (set Show
Settings to All) and Input / Codecs and increasing the value of Disc caching (ms) to maybe 5000 or 20000. Remember
to press Save to save VLC settings and restart VLC after that to make sure changes are enabled.

If DVD files from your hard drive work better, then check that your DVD drive has DMA enabled (if it is a IDE/ATAPI
DVD drive).

Can I play DVD files (VOB+IFO) from my hard drive?

Yes, you can. Use Media -> Open Disc. . . and instead of a DVD drive, point to the location of the correct folder by
using either Browse. . . button or the customize field. For example: dvd://”c:moviesBLOOD DIAMONDVIDEO_TS”

How do I handle the broken AVI files?

Some AVI files may give The AVI file is broken. Seeking not work correctly. Do you want to try to repair (this might
take a long time) dialog. Those AVI files have some issues and you can try to fix those files temporarily with VLC or
permanently with other tools. If you don’t fix those files, seeking won’t work correctly and those files may also crash
other players.

Can I always perform the same repair action?

Yes, you can. This can be done from Tools -> Preferences (set Show Settings to All) and Input / Codecs -> Demuxers
-> AVI and select the wanted action from Force index creation dropdown box. Ask is default (it will always ask what
you want to do). Always fix tries to always fix AVI files and Never fix always starts the playback without fixing.
Remember to press Save to save VLC settings and restart VLC after that to make sure changes are enabled.

Can I fix those broken AVI files permanently?

Yes. You can try for example DivFix++ or Virtualdub. If you still encounter any problem, read an answer given to a
VLC user on our forum if you encounter any issues.

Can I fix those broken or partially downloaded Matroska/MKV files too?

Yes. You can try Meteorite for fixing.

Some MP4 or 3GP files don’t have audio at all

If those files have AMR audio (usually ones from mobile phones) they might not work with current stable VLC
versions.
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How do I enable Blu-ray disc playback (for commercially released Blu-rays)

You have to download some additional files, here

Subtitles

How do I adjust subtitle delay?

During playback you can press h or g to adjust subtitle delay (adjust step is 50 ms).

How can I select the right subtitle track?

If your video has multiple subtitle tracks, you can select the one you would like to see from Video -> Subtitles Track.

Can I disable hardcoded or “burned” subtitles with VLC?

No, you can’t.

Can I change font, font size, style or color?

You can with text-based subtitle formats (Subtitles codecs). Go to Tools -> Preferences and Subtitles/OSD and adjust
anything you want. Remember to press Save to save VLC settings and restart VLC after that to make sure changes are
enabled.

How can I change the subtitles text encoding?

If you see wrong characters on screen or failed to convert subtitle encoding error message you should try to change
Default encoding option which can be found from Tools -> Preferences and Subtitles/OSD. Remember to press Save
to save VLC settings and restart VLC after that to make sure changes are enabled.

General

How do I reset my VLC settings?

If you can start VLC, go to Tools -> Preferences and then click on the Reset Preferences button and Save to reset the
existing VLC settings. Remember to restart VLC after that to make sure changes are enabled.

If you can’t start VLC, go to %appdata% folder and delete the vlc folder from there (Start -> run and type %app-
data%vlc there and press OK if you can’t locate %appdata%).

Also start menu -> VideoLan -> “Reset VLC media preferences . . . ”

Why does my VLC media player crashe on startup?

This usually happens because VLC setting files have been corrupted. Resetting VLC settings should fix this.
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Can VLC burn CD, DVD, HD DVD or Blu-ray discs?

No, you can’t.

Is VLC legal in all countries?

Probably not. The DeCSS module might violate DMCA (and similar laws), and some codecs would require licenses
for personal/commercial use. There haven’t been any court cases related to VLC, but companies should make sure
they pay license fees to license holders if they use VLC commercially and use patented formats or codecs.

Can I run multiple VLC instances?

Yes, you can.

How can I make VLC preview my eMule downloads?

Check out this forum post.

How do I specify the folder where the recorded files (via red rec button) will be stored?

Tools → Preferences and Input & Codecs and Record directory or filename. Remember to press Save to save VLC
settings and restart VLC after that to make sure changes are enabled.

See also:

Get Help - Find an answer to any question that wasnt answered here.

FAQs about VLC on Linux

Find below frequently asked questions about VLC on Linux;

How can I fix this error - “cc1: error: invalid option ‘tune=opteron’”

The -mtune flag is not available for this type of processor in man gcc. To solve this, change the configure options and
comment out all the lines where they set mcpu or mtune flags.

How can I fix this error - “/usr/bin/ld: cannot find -lX11”

In the configure, there is an x_libraries variable there that is set to “/usr/X11R6/lib” (around line 16371). Because it is
a 64 bit system, this variable needs to be /usr/X11R6/lib64. After changing that, it should continue compiling.

Missing header file ffmpeg/avcodec.h” and/or “Missing header file postproc/postprocess.h”

This problem can be solved with any of the two solutions below;

1. To get rid of these problems while compiling, run configure with these flags at least: ./configure –enable-shared
–enable-shared-pp –enable-pp –enable-gpl. The description of each of those is available when doing ./configure
–help
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2. The path of ffmpeg is not set. Check if you can locate the file libavcodec.pc on your computer; say you had find it
in /home/you/ffmpeg/ . Export the PKG_CONFIG_PATH to this location: export PKG_CONFIG_PATH=/
home/you/ffmpeg/ then run ./configure for VLC.

Legal concerns

May I use the VideoLAN logo?

You may freely use the VideoLAN logo using this copyright - Copyright (c) 1996-2018 VideoLAN. This logo or a
modified version may be used or modified by anyone to refer to the VideoLAN project or any product developed by the
VideoLAN team, but does not indicate endorsement by the project.

Are there any restrictions about usage of VideoLAN software?

No, you can use the software in the way you want, for personal, educational, professional or research use.

May I redistribute a piece of VideoLAN software?

Yes, you may distribute an original or a modified version of a piece of VideoLAN software as long as you comply with
its license terms. It is the GNU General Public License Version 2 (referred herein as GPL), and it is in the file named
COPYING in our products.

Note: You do not need to ask the VideoLAN team for permission to do so!

May I redistribute libVLC in my application?

Yes, you may distribute an original or a modified version of libVLC as long as you comply with its license terms. It is
the GNU Lesser General Public License Version 2 (referred herein as LGPL), and it is in the file named COPYING.LIB
in the VLC source distribution.

Note: Beware that some modules are licensed under the GPLv2, in which case you must license your result under the
GPLv2 as well. Check the modules in question before redistribution!

How do I do comply with those terms?

The easiest way to conform to the GPL is to accompany the product you want to distribute with its sources. For
example, if you plan to distribute the latest binary version of VLC on a DVD-ROM, you should also include the VLC
sources on the same medium. If you plan to distribute the latest binary version of VLC on a website, you should
provide a link to the VLC sources. There are other ways to comply with the GPL, but this should be the simplest
because it does not rely on a contract.

What about personal/commercial usage?

Some of the codecs distributed with VLC are patented and require you to pay royalties to their licensors. These are
mostly the MPEG style codecs. With many products the producer pays the license body (in this case MPEG LA) so
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the user (commercial or personal) does not have to take care of this. VLC (and ffmpeg and libmpeg2 – which it uses
in most of these cases) cannot do this because they are Free and Open Source implementations of these codecs. The
software is not sold, and therefore the end-user becomes responsible for complying with the licensing and royalty
requirements. You will need to contact the licensor on how to comply with these licenses. This goes for playing a
DVD with VLC for your personal enjoyment ($2.50 one time payment to MPEG LA) as well as for using VLC for
streaming a live event in MPEG-4 over the Internet.

Is libdvdcss legal?

The use and distribution of the libdvdcss library is controversial in a few countries such as the United States because
of a law called the DMCA (Digital Millennium Copyright Act). If you are unsure about the legality of using and
distributing this library in your country, please consult your lawyer.

Warning: VLC media player binaries are distributed with the libdvdcss library included.

See also:

Get Help - Find an answer to any question that wasnt answered here.

2.6.2 Get Help

VLC is a free and open source software which means that most developers are volunteers. Therefore, please remember
that every user support is provided by volunteers doing it in their free time. If you have problems that has not been
answered on our Frequently Asked Questions page, you can reach out to us diretly through any of the methods listed
below;

IRC

The VideoLAN IRC channel is a good way to contact and speak with the team. Using an IRC client, connect to
irc.videolan.org or irc.freenode.net and go on the #videolan channel. If you are in a location without direct IRC
access, please try the Freenode Webchat.

Forum

Search or ask your question on the VideoLAN support forum

Email

To contact us by e-mail, send a mail to videolan@videolan.org and write in either French, German or English.

Mail

If you need to send a postal mail to us, kindly mail it to the address below;

Postal Address
VideoLAN
18, rue Charcot
75013 Paris
France

2.7 Glossary

This page lists definitions for terms used in VLC and this documentation.
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Display locally This will display the stream on your screen. Here, effects of transcoding, rescaling, etc can be moni-
tored locally.

File This will allow you to save the stream to a file.

HTTP The HTTP streaming method allows you to specify the TCP port number you want to listen to.

IceCast The IceCast server can be used by specifying the address, port, mount point and authentication of the IceCast
server to stream to.

Left Mode (Audio) You can observe this in a regular audio player with 2.1 speakers. If you select the Left option,
the music is played only in the left speaker. The speaker on your right is automatically switched OFF.

Mono A monaural sound that uses a single channel for sound reproduction.

MS-WMSP (MMSH) This access method allows you to stream to Microsoft Windows Media Player by specifying
the IP address and TCP port number on which to listen. This will only work with the ASF encapsulation method.

Multicast This is a process where media files are sent to multiple systems through the network.

Reverse Stereo There are several applications that are used to reverse the stereo whereas VLC has an in-built feature
to reverse the stereo. This option is useful if you want the audio to play in tandem with the video. You can use
the Reverse Stereo option if you want to deliberately change the audio output. Imagine that you are watching
a video. In the video, a person walks on the left side but the sound is produced on the right speaker. You can
correct this by selecting the Reverse Stereo option in VLC. Select the Reverse Stereo option and play the same
scene in the video and observe the difference.

Right Mode (Audio) If you select the Right option, the music is played only in the speaker on your right side. The
speaker on your left is automatically switched OFF.

RTP The Real-Time Transfer Protocol is similar to UDP but it can use both unicast and multicast addresses.

Stereo This is the reproduction of the sound in two or more independent audio channels using more than one speaker.
If you use this option, you would feel as though the sound is played from all the directions. You can observe
this in a regular home theatre with 5.1 or 6.1 speakers.

UDP Stream in unicast by providing an address in the 0.0.0.0 - 223.255.255.255 range or in multicast by providing
an address in the 224.0.0.0 - 239.255.255.255 range. It is also possible to stream to IPv6 addresses. This will
only work with the TS encapsulation method.

Unicast This is a process where media files are sent to a single system through the network.
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